华三H3C: OSPF 明文v5和v7版本验证问题

  1. H3C 路由器和交换机的版本 V5 和 V7
    目前大多数真实机的软件版本几乎都是 V7 少部分是 V5
    但是目前的 H3C 模拟器比如 Lito 模拟器 HCL 都是运行的 V5 版本
    所以在实际工作环境中就是出现一些问题,
    下面直接介绍在 V5 版本交换机和 V7 版本路由器之间建立 OSPF 明文验证的解决方法:
  2. 实验拓扑:
  3. 具体步骤
    思路:V5 版本需要在 ospf 的 area 下配置 ospf 验证方式为明文,然后再在接口视图下指定具体的明文内容
    V7 版本不需要在 ospf 的 area 下配置任何东西,只在接口视图下指定 ospf 的验证方式及明文内容

3600 交换机配置如下:

ospf 10 router-id 9.9.9.202

area 0.0.0.0

authentication-mode simple

network 10.0.0.0 0.0.0.3

network 10.0.10.0 0.0.0.255

network 9.9.9.202 0.0.0.0

interface Ethernet1/0/1

port link-mode route

ip address 10.0.0.1 255.255.255.252

ospf authentication-mode simple plain 123456

2630 路由器配置如下

ospf 10 router-id 9.9.9.3

area 0.0.0.0

network 9.9.9.3 0.0.0.0

network 10.0.0.0 0.0.0.3

network 10.0.0.4 0.0.0.3

interface GigabitEthernet0/0

port link-mode route

ip address 10.0.0.2 255.255.255.252

ospf authentication-mode simple plain 123456

4. 查看结果:

dis ospf peer

     OSPF Process 10 with Router ID 9.9.9.3
           Neighbor Brief Information

Area: 0.0.0.0

Router ID Address Pri Dead-Time State Interface

9.9.9.202 10.0.0.1 1 33 Full/BDR GE0/0
成功在明文验证上建立 OSPF 邻居关系


打赏

华三H3C: OSPF 明文v5和v7版本验证问题:等您坐沙发呢!

发表评论